The tales of Vista, part one

September 27, 2006 at 10:46 PMJoshua Harley

This is going to be a three part piece because I have installed Windows Vista on three different machines with three radically different results... go figure right?

The first machine I installed Windows Vista RC1 (build 5600) on was my personal laptop, an HP Pavilion zv6000 custom. (AMD Athlon 64 3200+, 512MB RAM, 40GB hard drive, ATI Radeon Express 200M 128MB). Because of how I am, I installed the 64-bit edition of Vista, and I have to say, while it isn't fast, it has yet to cause me any problems with that install... just the hard drive going almost constantly... but here in a few months I will be upgrading the RAM to somewhere in the 1.5GB range (new optical drive too - from a dvdrom/cd-rw to a dual layer dvd-rw/cd-rw).

Driver support for Vista x64 still bothers me a lot, you must have signed drivers to load, and they have to be written for Vista. There are, of course, exceptions to this rule, aka. pressing F8 and selecting Disable Signed Drivers Policy (I think...). This holds true for my desktop too, we need to get signed drivers out there, or reallow the option of the bcdedit /set nointegritychecks ON command! Thankfully if I don't do that step the only thing that isn't loaded is my sound card. I did manage to use Windows XP x64 drivers for the built in card reader, and modem. Somehow those are signed and work fine in Vista with no problems at all. To get the ATi southbridge soundcard working I had to search for the Audio64.zip file found somewhere on the www.planetamd64.com site. I'll find a direct link and post it here for future reference.

I don't remember the rating of my machine, but it isn't too bad for its setup, the largest limiting factor being the amount and speed of the RAM followed by the 4200RPM speed of the hard drive. One feature I can attest to working is their new ReadyBoost feature. Using the built in memory card reader (SD, XD, MMC, MemoryStick, etc.) I can use my 1GB SD card as extra RAM for its cache file. Let me tell you, once you say it can use it, it will... almost every operation I can see that little light blinking, and after a few minutes of it being loaded, I noticed a performance increase. I kid you not, totally awesome!

For those of you wondering, the Vista Aero theme (previously known as Glass) does run on the ATi Radeon Xpress 200M video card, but be prepared to wait for a bit. I will post an update to let you know if upgrading the hard drive to a faster speed will help, because I am sure that limits it as well. A few things I have tested with it are Visual Studio 2005 which runs flawlessly and Guild Wars which runs just like it did in XP. Guild Wars was always a little jumpy in areas, once again I am sure this is tied to my RAM so that will be the first component I upgrade.

The next time I use my laptop I will post its score, so you can see how it compares to other machines out there.

To wrap part one up, I am very impressed with Vista working on my laptop. The only problems I have had is it not going to Sleep or it not successfully resuming from Hibernate. Things that worry me include the lack of driver support, and the requirement to sign them... I don't know if this is a good move or not! HP isn't known for releasing new drivers (hell, the pricks don't provide drivers for my HP Color LaserJet 2600 for x64 edition! what the hell?) and I won't be surprised to need to hit f8 everytime my laptop boots to enable unsafe drivers.

Posted in: Vista

Tags:

Updated Blog

September 19, 2006 at 1:12 AMJoshua Harley

Well, some of you might have noticed that the site was down for a few hours today. I finally downloaded the SVN version of dasBlog and finally, after a few hours, managed to get it working. What doesn't matter to you (but does to me) is I now have the source code sitting on my desktop here so I can add, change, and update the code as I see fit. This will make it much easier to create my own modules and other things because I compile the website myself instead of using a precompiled download. This also allows me to update to the latest SVN version as they commit changes. Another change I have made to the website is the addition of the /media directory, simple theme images and required images will now be in the /images folder and any other media (music, movies, pictures) that I post to the website will now appear under /media. I have already gone through my last few posts and updated the tags to point to the new location, if you find any let me know ([email protected]).

As it stands, I am liking this new theme that was supplied and I was thinking of modifying it, but I'm not sure how. So keep an eye out. Oh yeah! Captcha images should also work now for comment posting.

Posted in: Site Information

Tags:

Hauppauge Win-PVR-350

September 6, 2006 at 11:53 PMJoshua Harley

It came today, my Hauppauge Win-PVR-350! It was quite a hassle to get it working, as the directions for installing the ivtv driver under linux wasn't that clear. It only took me about an hour and a half to get that part working. So my linux system recognizes it and I am able to pipe video from its input (/dev/video0) to its output (/dev/video16). To watch TV "live" (there is a 3 second delay after all) all I have to do is:

% dd if=/dev/video0 of=/dev/video16 bs=64k

and if I want it recorded I type

% dd if=/dev/video0 of=/var/some/path/file.mpg bs=64k

To play it back

% dd if=/var/some/path/file.mpg of=/dev/video16 bs=64k

Pretty neat isn't it?

Unfortunately I haven't gotten everything working, for some reason Xorg (the window display system) refuses to compile its driver to show on the output of the card. I was running 7.1 (the latest stable) but I have heard that going back to 6.9 should fix the problem. Once I can get X showing on the TV all I have to do then is recompile the libraries that pointed to Xorg 7.1, including Qt, and then compile and install MythTV. Once that goes off, I should be done... or at least have it usable.

On an entirely AWESOME note, I found out last night that the remote that came with the PVR-350 CAN be used to control MythTV! How awesome is that? Wooo!

Well, wish me luck!

Posted in:

Tags: , ,